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What's New in P6 Professional Release 8.3

Visualizer

Visualizer is a new feature that supports graphical reporting by enabling users to create
customizable Gantt charts and timescaled logic diagrams (TSLDs).

In addition to the P6 Professional’s standard graphical features, Visualizer enables a user to:
e Stack columns and use word wrapping in the Gantt chart.
e Use notebook topics or a list of steps as a bar label or as an field in the activity table.
e Apply various fonts to individual labels and fields.
e Color-code and apply different shapes for bars and endpoints.
e Draw bars on top of each other, for example, to show critical highlighting.

Visualizer is a desktop application that can be launched either from within Pé Professional or from
the computer’s start menu. It has a direct connection to the Pé database and provides live
access to all Pé projects.

When Visualizer is launched, it displays a workspace where you can add, open, print and manage
layouts. You also can import Pé Professional layouts or Visualizer layouts from other users.

Choose to create or open a TSLD or Gantt chart. The Gantt chart includes a grid and a bar chart.
The grid displays activity information in a table format, similar to the Activity Table in P6 Professional.
On the Chart & Grid tab in Layout Options, display the Gantt chart, the grid, or both. TSLDs enable
you to display more than one activity per row, which condenses the project plan and the chains of
activities that drive the project schedule.

You can run Visualizer layouts in batches for faster periodic reporting. Using a tool like Windows
Scheduler, schedule the batch runs of reports in advance.




When creating layouts, Visualizer obeys settings specified in Admin Preferences in P6 Professional. If
Pé Professional is connected to a P6 EPPM database, it obeys Application Settings in Pé:

e Weekday on which the calendar week begins
e Number of work hours for fime periods and time abbreviations

¢ Online Help settings
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When creating a layout in Visualizer you can define options, such as filter, group, and sort criteria,
to customize the Gantt chart or TSLD. The layout below shows activities color-coded by activity
code values with various shapes for endpoints.
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Display baseline bars to compare schedules and stack fields in the activity table to save horizontal
space.
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The screen below shows an example of a TSLD with multiple bars per activity and critical activities
coded inred.
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To access this feature:
In P6 Professional, click Visualizer on the Tools menu or open it directly from the Start menu.




Discussion Feature

P6 Professional provides a new Discussion feature that enables team members and project
managers to communicate about specific activities. All comments are dated and labeled with the
conftributor's name. They are saved with the activity for future reference, allowing contributors to
view the entire discussion thread before posting a new comment. Read or add comments in the
Discussion tab in the Activities window.
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A new column, Unread Comments, is available in the Activites window to alert project managers
to comments awaiting review. The feature can also be accessed through Team Member Web, the
Team Member for iPhone app, and Pé.
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To access this feature:

In the Activities window, select a task and then click the Discussion tab.




XML Import/Export Enhancements

P6 Professional R8.3 provides a number of enhancements to its XML import/export functionality. A
user can now exchange XML project files with previous version of Pé Professional from Ré.2 SP4
onward. Also, all features supported by the P6 Professional XER format -- constraining of external
relationships during import, inclusion of Price/Unit in resource assignments, import of Past Period
Actuals -- are supported in XML format as well.

P6 Professional R8.3 also enables a user to import or export multiple projects simultaneously. When
exporting multiple projects, the projects are combined into a single XML file. Importing multiple
projects requires the projects to be contained in a single XML file.

Projects To Export

Select which project to export from the list of currently open projects belaw .

Open Projects

Export Project ID Project Mame
City Center Office Building Lddition

¥ ECO0530 Meshid Building Expansion
¥ ECO0501 Haitang Corparate Park

ASelect a check box in the

Export column to include the
project in the exported XML file.

To access this feature:

On the File menu, click Import, or click Export, and then select Primavera P6 - (XML). Click Next to
select the projects to import or export.




Granular Control Over Data During XML Import

A new screen in P6 Professional R8.3's XML project import process enables a user to view data in the
incoming file and adjust it as necessary before importing it into the database.

This feature is especially useful to project managers who import third-party schedules that contain
data such as resources, calendars, codes, and UDFs. They may want to modify that data to match
their own data structures. In previous versions of P4, they manually scanned and then modified the
data before importing .

New import options include the ability to:
e Move global codes and calendars to project-level data or remove them from the import.

e Map codes, UDFs, resources and calendars to existing values in the database or rename
them.

e Specify resource locations for importing resources into a selected hierarchy.

Import options can be saved as a template for use in subsequent imports.
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To access this feature:

Click the Advanced tab on an XML import template.
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Exporting Project Data to UN/CEFACT

P6 8.3 includes support for the UNCEFACT XML schema schedule format. This XML schema is
designed to exchange schedule and cost data in a software-neutral format. This is an important
feature for customers who work with U.S. Department of Defense and other U.S. government
agencies because as of June 2012 they are required to submit their schedules in the UN/CEFACT
XML schema format.

Export Format

Select the export format.

" Primavera PM - (XER)

™ Primavera Cantractor - (KER)

(" Primavera PE - [XhL)
(" Spreadshest - (XLS)
~

" Microsoft Project |
Choose to export
projects in UN/CEFACT
(XML) format.

To access this feature:

On the File menu, select Export.
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Using Online HTML Help

The Help menu in P6 Professional 8.3 contains two options: Local Help and Online Help. The Online
Help feature displays Pé Professional help content in basic HTML format, enabling people with
disabilities to use the adaptive features of their browsers.

2 Primavera P6 Professional RB.3 : ITO0351 (Project Swordfish)

. File Edit Wiew Project Enterprise Tools  Admin
=) : — ] - — Local Help. .. Chrl4+F1 =
' =] Options available on (%) Online Help... ChralE+F
Activitie the Help menu.
About Primavera P& Professional.
= = Layout: Clazsic Schedule Layout rrnEr T Etivi
] Activity D Activity Mame Urread | Start
Commerits
‘__ - ITOO351 Project Swordfish 0 04-Apr-11 &
- ITOO351 .99 Key Miestones 0 o7-Apr-11
Il IT2001 Project Start Milestone
e ..- IT9002 Gate 1 - Project Funding &pproved
E]] IT9003 Gate 2 - Reguirements Approved
J IT9004 Gate 3 - Coding Complete
‘H IT9005 Gate 4 - Ready for Implementation
IT900E Project Complete Milestone
== - ITOD351.0 Initistion Phase
l". IT1000 Explare Cpportunity 0 04-Lpr-11 &
— i T 0 07-Apr-11 &
T adar 0 07-2pr-114

———

Choose Online Help from the Help menu to launch an URL you specify on the Options tab in the
new Pé Professional Online Help section in Admin Preferences. The URL defaults to the location of
the R8.3 files on Oracle Technology Network (OTN). If this field is blank, online help is no longer
available and local help launches.

Choose Local Help to have the Help menu behave the same as Contents does in Pé Professional
R8.2 and earlier. The HTML Help files are installed locally when Pé Professional is installed. Click Local
Help to launch the local file. By default, the installation location is \\Oracle\Primavera P6\Pé
Professional\Help.

The Always launch Online Help for the F1 shortcut key and context-sensitive help check box in
Admin Preferences determines which Help system loads when using the F1 key and launching
context-sensitive pages. Select the check box to launch online help from the specified URL
location. By default, the check box is not selected, meaning local help is launched when a user
uses the F1 key.

To access this feature:
Click the Options tab in Admin Preferences.
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Loading Resource Summary Data on Startup

The new Resource Summary data setting in the Startup Filters tab of User Preferences enables a
user to choose whether this type of data will load aft startup. If the Resource Summary data check
box is selected, Pé Professional may take longer to start and some views may take longer to load.
Prior to R8.3, this setting was stored in the registry. It was moved to startup filters to enable easier
access by users. The setting also affects whether to use resource and role data during project
summarization.

A user also can choose the data filters to run when starting Pé Professional. Startup filters are
available for Oracle and SQL Server installations.

-
User Preferences

Time Unit= Startup Fitters

Dates Chooze the default fitters to start the application. If you chooze to
vienwy all data the application may take longer to start. These fiters
can be modified in the individual views.

Currency

E-Mail

Current project Wiewy all data

Assizt
ssistance data only (Mo Fitter)

Application

Paz=zword Resources

Resource Analysis Roles

oBs

Calculstions

Startup Fitters &ctivity Codes

Cost Accourts

Us=e the following setting to determine whether this type of data wil
load &t startup. If you choose to load the data, the application may
take longer to start and some viewws may take longer to load. If using a
PE Professional database, this setting will alzo affect whether to uze
resource and role data during project summarization.

[v Resource Summary data

Clear the check box to not
load resource summary
data on startup.

To access this feature:
On the Edit Menu, click User Preferences. Click the Startup Filters tab.
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Legal Notices

Oracle Primavera What's New in Pé Professional

Copyright © 1999, 2013, Oracle and/or its affiliates. All rights reserved.
Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be
trademarks of their respective owners.

This software and related documentation are provided under a license agreement containing
restrictions on use and disclosure and are protected by intellectual property laws. Except as
expressly permitted in your license agreement or allowed by law, you may not use, copy,
reproduce, translate, broadcast, modify, license, tfransmit, distribute, exhibit, perform, publish or
display any part, in any form, or by any means. Reverse engineering, disassembly, or
decompilation of this software, unless required by law for interoperability, is prohibited.

The information contained herein is subject to change without notice and is not warranted to be
error-free. If you find any errors, please report them to us in writing.

If this is software or related documentation that is delivered to the U.S. Government or anyone
licensing it on behalf of the U.S. Government, the following notice is applicable:

U.S. GOVERNMENT END USERS: Oracle programs, including any operating system, integrated
software, any programs installed on the hardware, and/or documentation, delivered to U.S.
Government end users are “commercial computer software" pursuant to the applicable Federal
Acquisition Regulation and agency-specific supplemental regulations. As such, use, duplication,
disclosure, modification, and adaptation of the programs, including any operating system,
integrated software, any programs installed on the hardware, and/or documentation, shall be
subject to license terms and license restrictions applicable to the programs. No other rights are
granted to the U.S. Government.

This software or hardware is developed for general use in a variety of information management
applications. It is not developed or intended for use in any inherently dangerous applications,
including applications that may create arisk of personal injury. If you use this software or hardware
in dangerous applications, then you shall be responsible to take all appropriate failsafe, backup,
redundancy, and other measures to ensure its safe use. Oracle Corporation and its affiliates
disclaim any liability for any damages caused by use of this software or hardware in dangerous
applications.

This software or hardware and documentation may provide access to or information on content,
products and services from third parties. Oracle Corporation and its affiliates are not responsible for
and expressly disclaim all warranties of any kind with respect to third-party content, products, and
services. Oracle Corporation and its affiliates will not be responsible for any loss, costs, or damages
incurred due to your access to or use of third-party content, products, or services.
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