
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

New Features 
in Primavera P6 Professional 8.4 

 

 

September 2014 

 

 



  

COPYRIGHT & TRADEMARKS 

Copyright © 2014, Oracle and/or its affiliates. All rights reserved. 

Oracle is a registered trademark of Oracle Corporation and/or its affiliates. Other names may be trademarks of their respective 
owners. 

This software and related documentation are provided under a license agreement containing restrictions on use and disclosure and 
are protected by intellectual property laws. Except as expressly permitted in your license agreement or allowed by law, you may 
not use, copy, reproduce, translate, broadcast, modify, license, transmit, distribute, exhibit, perform, publish or display any part, in 
any form, or by any means. Reverse engineering, disassembly, or decompilation of this software, unless required by law for 
interoperability, is prohibited. 

The information contained herein is subject to change without notice and is not warranted to be error-free. If you find any errors, 
please report them to us in writing. 

If this software or related documentation is delivered to the U.S. Government or anyone licensing it on behalf of the U.S. 
Government, the following notice is applicable: 

U.S. GOVERNMENT RIGHTS 
Programs, software, databases, and related documentation and technical data delivered to U.S. Government customers are 
“commercial computer software” or “commercial technical data” pursuant to the applicable Federal Acquisition Regulation and 
agency-specific supplemental regulations. As such, the use, duplication, disclosure, modification, and adaptation shall be subject to 
the restrictions and license terms set forth in the applicable Government contract, and, to the extent applicable by the terms of the 
Government contract, the additional rights set forth in FAR 52.227-19, Commercial Computer Software License (December 2007). 
Oracle USA, Inc., 500 Oracle Parkway, Redwood City, CA 94065. 

This software is developed for general use in a variety of information management applications. It is not developed or intended for 
use in any inherently dangerous applications, including applications which may create a risk of personal injury. If you use this 
software in dangerous applications, then you shall be responsible to take all appropriate fail-safe, backup, redundancy and other 
measures to ensure the safe use of this software. Oracle Corporation and its affiliates disclaim any liability for any damages 
caused by use of this software in dangerous applications. 

This software and documentation may provide access to or information on content, products and services from third parties. Oracle 
Corporation and its affiliates are not responsible for and expressly disclaim all warranties of any kind with respect to third party 
content, products and services. Oracle Corporation and its affiliates will not be responsible for any loss, costs, or damages incurred 
due to your access to or use of third party content, products or services. 

 

 

NOTE: Duplication or distribution of this document without written permission from Oracle Corp. is prohibited. 

 



 

 

CONTENTS 

New Features in Primavera P6 Professional 8.4 ...........................................1 
Manage Baselines as Job Services ..................................................................2 
Import XML as a Job Service ..........................................................................3 
Interface Changes with SQLite Database ........................................................4 
Visualizer Enhancements ................................................................................6 

Shift as a Date Interval ..................................................................................7 
Include Legend in Header or Footer .............................................................8 
Manage Multiple Layouts Simultaneously ...................................................9 
Copy Bar Settings .......................................................................................10 

Integration with Primavera Prime .................................................................11 
Integration with Primavera Unifier ...............................................................12 



New Features in Primavera P6 Professional 8.4 

 

 1

New Features in Primavera P6 Professional 8.4 
New features in Primavera P6 Professional 8.4 include: 

 Integration with Primavera Prime and Primavera Unifier 
 New Visualizer functionality 
 Usability enhancements 
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Manage Baselines as Job Services 
In P6 Professional 8.4, the add, copy, and update baseline functions now run as job services, enabling you to 
work while the processes run in the background of the application. You will receive a notification after a 
service is completed. This functionality is not available if P6 Professional is a standalone install. 
  

 
  
To access this feature:    
On the Project menu, click Maintain Baselines. In the Maintain Baselines dialog box, click Add, Copy, or 
Update. 
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Import XML as a Job Service 
In P6 Professional 8.4, importing projects in XML format is performed as a job service. Projects imported in 
Primavera P6 XML or Microsoft Project XML formats run as a scheduled job, allowing you to continue 
working in the application while the file is importing. You will receive a notification after the import is 
completed. This functionality is not available if P6 Professional is a standalone install. 
  

 
  
To access this feature: 
On the File menu, click Import. 
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Interface Changes with SQLite Database 
An embedded SQLite database has replaced the use of Oracle XE for P6 Professional Standalone 8.4. 
 
Because of its single-user nature, several changes have been implemented in the standalone version of P6 
Professional: 

 Users and Security Profiles dialog boxes are disabled, as there is only one user. 
 In the Open Project dialog box, the Access Mode options are hidden. All projects are opened in 

Shared mode. 
 Sending e-mail notifications of Project Issues is not supported. 
 Advanced import options are disabled for projects in XML format. 
 Check In and Check Out on the File menu are disabled. 
 The All Users and Another User options in various Available to lists are disabled. 
 Job Services is not supported. Jobs cannot be scheduled. 
 Update Baseline, Risk Analysis, and Claim Digger are not supported. 
 Java-based integration components developed by the customer using the P6 Remote Integration API 

(RMI) are not supported with the SQLite database. 
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Visualizer Enhancements 
 New Visualizer functionality enables you to add legends to your headers and footers, add shifts as date 
intervals, copy chart bar settings, and manage multiple layouts at the same time. 
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Shift as a Date Interval 

In P6 Professional 8.4, Visualizer allows you to display shifts on a Gantt chart or timescale logic diagram. 
Choose Shift as a Date Interval on any of the three timescales in the Timescale tab, and then choose a shift 
in the Shift Calendar list. Common shift calendars include one- or three-shift operations. Shifts are managed 
in the Resource Shifts dialog box of P6 Professional.  
  

 
  
To access this feature: 
On the Timescale tab in Visualizer, select Shift from the Date Interval list. 
  



New Features in Primavera P6 Professional 8.4 

 

 8 

Include Legend in Header or Footer 

In P6 Professional 8.4, insert a legend into the header or footer of a Visualizer chart. Customize the font and 
alignment; add images, tables and variables; and add, delete, or resize sections. Variables for the legend 
include dates, bars, activity codes, and lines. A separate set of variables can be selected for legends in the 
header and footer. 
  

 
  
To access this feature: 
In the Page Setup tab in Visualizer, open the Title Block tab. 
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Manage Multiple Layouts Simultaneously 

In P6 Professional 8.4, Visualizer enables you to select one or more layouts in the Manage Layouts dialog 
box. Paste layouts from one grouping to another, move a selection of layouts to the Global layout grouping 
band (for User or Project layouts), or move a selection of layouts to the Project layout grouping band (for 
User layouts only).  
 

 
  
To access this feature: 
Open the Manage Layouts dialog box in Visualizer. 
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Copy Bar Settings 

In P6 Professional 8.4 Visualizer, copy an existing bar to create layouts quicker and simpler. Copy existing 
bars and then modify them to create new bar definitions. 
  

 
  
To access this feature: 
Open the Bars & Labels tab in Visualizer. In the Available Bars section, click Copy. 
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Integration with Primavera Prime 

A P6 Professional environment that is connected to an EPPM database integrated with Primavera Prime can 
exchange data for risk analysis and scope management. 
 
Risk anaylsis: To run a risk analysis in Prime, project data must be imported from an integrated EPPM 
database. Ensure that the prerequisites for running a risk analysis are satisfied: establish activity and risk 
data; create response plan details; enter uncertainty estimates for project activities; and schedule the project. 
Risk data includes risk thresholds, risk scoring matrices, and mapping risks to activities. All risk data and 
uncertainty estimates must be entered in P6 Web interface. After running the risk analysis in Prime, the 
Update from Primavera Prime process updates pre- and post-response pessimistic dates for activities. This 
data is stored in the database and is not visible in P6 Professional. 
 
Scope management: Scope management integration allows you to manage the costs and schedules of scope 
items at the activity level. Scope items are materials used in an activity; a work package is a bucket of short-
term work used to manage installation of related scope items. In Prime, scope items are assigned to work 
packages. Work packages are sent to P6 Professional as leaf-level WBS nodes. In P6 Professional, add 
activities to work packages to provide a greater level of detail to the project. Activity data created in P6 
Professional can be sent back to Prime to update work package dates and costs. 
 

 
To access this feature: 
On the File menu, click Exchange Data, Send to Primavera Prime or Update from Primavera Prime.  
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Integration with Primavera Unifier 

Enhanced integration in P6 Professional 8.4 enables cost analysis of P6 data in Unifier. 
 
Summarized duration, unit, and cost data is exported from P6 Professional to Unifier. The type of data 
exported is based on the schedule in P6 Professional: Duration-based schedules send just duration data; 
resource-loaded schedules send duration and unit data; cost-loaded schedules send duration, unit, and cost 
data. 
 
Assign Cost Breakdown Structure codes to activities, resource assignments, and expenses in P6 
Professional. These cost codes are imported into P6 Professional from Unifier and are used to summarize P6 
Professional data in Unifier's cost sheet. 
 
When the data is exported from P6 Professional, projects are linked via Primavera Gateway: The P6 
Professional Project ID maps to a Project Number in Unifier. 
 
In Unifier, a summary sheet displays summary data for each project -- one for the project and one for each 
baseline, up to 12 total sheets. 
 
Use Unifier's advanced costing, cash flow, and earned value functionality to analyze P6 Professional data. 
 
Integration between P6 Professional and Unifier will run as a job service in the background of the 
application. Integration can be scheduled to run at a set time or on-demand. Integration with Unifier requires 
P6 Professional to be connected to a P6 EPPM database. 
 

 
To access this feature: 
On the File menu, click Exchange Data, Send to Primavera Prime or Update from Primavera Prime. 


